Service updates

A snapshot of the giffgaff service

Issue receiving MFA codes
Incident Report for giffgaff
Resolved
We had recently been advised that some members were not receiving an MFA (Mult-Factor Authentification) code when requested. I am glad to confirm our technical team have investigated this issue and it has now been resolved. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34040606-restored-issue-receiving-mfa-codes-10th-april-2024
Posted Apr 12, 2024 - 16:11 BST
Investigating
We have been advised that some members are not receiving an MFA (Mult-Factor Authentification) code and are unable to change how they receive the code. The relevant technical teams are aware and are investing . Read more here
Posted Apr 10, 2024 - 15:28 BST
This incident affected: giffgaff communications (Two-step verification).