Service updates

A snapshot of the giffgaff service

Issue with SIM ordering service - 12 April 2024
Incident Report for giffgaff
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 14:34 BST
Monitoring
The technical team has informed us that this issue is now resolved and members are able to order sims again without facing an error message. We will of course continue to monitor over the next few days.

https://community.giffgaff.com/d/34041752-issue-with-sim-ordering-service-12-april-2024
Posted Apr 12, 2024 - 18:24 BST
Investigating
We are currently experiencing some unexpected issues with our SIM ordering service. Members may receive the error “There’s an error with ordering your SIM – please try again later.” when placing an order. We are finding that ⅔ of orders are still going through, despite this message appearing. Our technical team is currently investigating this.
Posted Apr 12, 2024 - 09:42 BST
This incident affected: SIM (Ordering a SIM).