Service updates

A snapshot of the giffgaff service

Issue with SIM ordering service
Incident Report for giffgaff
Resolved
We recently experienced some unexpected issues with our SIM ordering service. Members may have received the error “There’s an error with ordering your sim – please try again later.” The order however will have gone through. I am pleased to confirm this issue has now been resolved. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34035438-restored-issue-with-sim-ordering-service-03-april-2024
Posted Apr 05, 2024 - 09:36 BST
Update
We are currently experiencing some unexpected issues with our SIM ordering service. Members may receive the error “There’s an error with ordering your sim – please try again later.” The order however does go through. Our technical team are currently investigating. You can learn more on this Service Issue via our community - https://community.giffgaff.com/d/34035438-issue-with-sim-ordering-service-03-april-2024
Posted Apr 04, 2024 - 10:40 BST
Investigating
We are currently experiencing some unexpected issues with our SIM ordering service. Members may receive the error “There’s an error with ordering your sim – please try again later.” The order however does go through. Our technical team are currently investigating. You can learn more on this Service Issue via our community - https://community.giffgaff.com/d/34035438-issue-with-sim-ordering-service-03-march-2024
Posted Apr 03, 2024 - 09:45 BST
This incident affected: SIM (Ordering a SIM).