Service updates

A snapshot of the giffgaff service

Physical SIM activation issues | 08 Sept 2026

Incident Report for giffgaff

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 12:18 BST

Update

We are continuing to investigate this issue.
Posted Sep 08, 2026 - 10:42 BST
This incident affected: SIM (Activating SIM).