Service updates

A snapshot of the giffgaff service

SIM Provisioning Delays - 07 July 2026

Incident Report for giffgaff

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 13:22 BST

Update

We are continuing to investigate this issue.
Posted Jul 07, 2026 - 13:22 BST

Investigating

There is an issue impacting all SIM provisioning requests and they are currently in a queued state. Read more here
Posted Jul 07, 2026 - 11:25 BST
This incident affected: Transferring your number (Joining giffgaff, Delayed Number Transfer), eSIM (Downloading eSIM, Installing eSIM), and SIM (Activating SIM, SIM Swap).