We were notified of technical issue earlier today, which impacted provisioning requests. Our technical team have identified the cause of the issue and full service has been restored. The remaining queued requests will be completed shortly.
Posted Feb 14, 2026 - 16:44 GMT
Identified
Our technical team are working on restoring full service and are working through the backlog of requests. A solution has been identified and we will keep you updated on progress here.
Posted Feb 14, 2026 - 14:57 GMT
Update
We are continuing to investigate this issue.
Posted Feb 14, 2026 - 10:53 GMT
Investigating
We’re currently dealing with a technical issue which is impacting provisioning requests. All requests are queued and will be fixed once service is restored
Posted Feb 14, 2026 - 10:53 GMT
This incident affected: Transferring your number (Joining giffgaff), eSIM (Installing eSIM), and SIM (Activating SIM, SIM Swap).