Service updates

A snapshot of the giffgaff service

Issue with 43430/43431 - 1 April 2025

Incident Report for giffgaff

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 12:18 BST

Investigating

Earlier this morning we received reports that our members were experiencing a small issue with IVR requests for 43430/43431, meaning members who attempted to call 43430/43431 won’t be able to call those numbers. To read more on this issue please see our community - Read more here
Posted Apr 01, 2025 - 10:19 BST
This incident affected: Transferring your number (Calling 43431, Texting 43431) and Buying plans and credit (IVR - Automated phone service).