Service updates

A snapshot of the giffgaff service

Calling 43430 - 20 October 2025

Incident Report for giffgaff

Resolved

Good news, the issue impacting members calling 43430 has been investigated and resolved. The service is now working as it should.
Posted Oct 20, 2025 - 13:09 BST

Investigating

This morning, we noticed that some members when calling 43430 received an error message of “Technical Issues”. Calling 43431 is working as it should. We are currently investigating the cause of this and will keep you updated here.
Read more here
Posted Oct 20, 2025 - 09:25 BST
This incident affected: Plans & Credit (IVR - Automated phone service).