Service updates

A snapshot of the giffgaff service

Delays for some members transferring their numbers
Incident Report for giffgaff
Update
Following a systems upgrade we’ve been made aware that some of our members are now experiencing delays when trying to transfer their numbers. We’re really sorry about this. The team is aware and working hard to get it resolved as soon as possible.

We can identify members that have been impacted by delays, so anyone impacted will be notified on their account dashboard and receive an email from us. The email will provide impacted members with more details about the issue as well as next steps the member can follow. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34189666-delays-for-some-members-transferring-their-numbers
Posted Oct 30, 2024 - 17:13 GMT
Investigating
We are aware of potential delays impacting some of our members when transferring their numbers in or out of our network. The team is on the case and working hard to get this resolved. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34189666-delays-for-some-members-transferring-their-numbers
Posted Oct 29, 2024 - 12:05 GMT
This incident affects: Transferring your number (Joining giffgaff).