Service updates

A snapshot of the giffgaff service

Issues with postcode lookup when placing phone order | 02 Sept 2026

Incident Report for giffgaff

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2026 - 17:05 BST

Investigating

We are seeing reports of some members experiencing issues with finding their address via postcode lookup while placing a phone order. Read more here
Posted Sep 02, 2026 - 16:05 BST
This incident affects: SIM (Ordering a SIM) and Phones (Phone order processing).