Service updates

A snapshot of the giffgaff service

Online activations stuck - 17 June 2025

Incident Report for giffgaff

Resolved

Good news, our technical teams have confirmed that any members affected by the activation issue from June 17th have been resolved, and any backlog has been cleared.
Posted Jun 19, 2025 - 16:19 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2025 - 13:59 BST

Investigating

We are seeing some Online activations and Lost and Stolen SIM Swaps are currently stuck, therefore some members that activated a SIM or requested Lost and Stolen SIM Swaps this morning between 08:17 - 10:06 may face a delay to that request completing. Read more here
Posted Jun 17, 2025 - 16:50 BST
This incident affected: Transferring your number (Joining giffgaff) and SIM (Activating SIM, SIM Swap).