Service updates

A snapshot of the giffgaff service

Issues logging into giffgaff.com and app
Incident Report for giffgaff
Resolved
We had recently been made aware that some members were unable to log in to their account and were presented with the error message ‘Oops, Sorry, something went wrong on our side. Try again in a few minutes’.

I am glad to confirm this issue has been resolved, and members impacted by this should now be able to log in. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34048943-restored-issues-logging-into-giffgaffcom-and-app-23-april-2024
Posted Apr 24, 2024 - 10:28 BST
Investigating
We have been made aware that some members are unable to log in to their account via both the website and app. Affected members are being presented with the error message ‘Opps, Sorry, something went wrong on our side. Try again in a few minutes’. Our technical team are currently investigating the issue. Read more here
Posted Apr 23, 2024 - 11:37 BST
This incident affected: The My giffgaff app (Login) and giffgaff.com website (Login).