Recently we confirmed that the issue causing physical SIM’s and eSIM’s not to activate is no longer occuring. Over the last few days our technical teams have been working to clear the small backlog of members who have still been impacted by this issue, and we’re glad to confirm the remaining SIMs that were impacted have now been activated.
Posted Dec 12, 2024 - 17:18 GMT
Update
We can confirm that the issue causing physical SIM’s and eSIM’s that was impacting activations from November 25th is no longer occurring.
There are still some members who are stuck in the activation stage and after further investigation from our technical team have confirmed that these are unrelated to this issue. The affected member’s activations are being worked on in an individual basis and any members impacted by this have been informed of the delay. Read more here
Posted Dec 10, 2024 - 11:44 GMT
Identified
Our technical team are continuing to work on the activation of SIMs from over the last few days, however new activations for today have been restored,
This means SIMs ordered from November 25th through November 28th are still impacted, however SIMs ordered on another date can now be activated. Our technical team are working through the backlog of SIMs ordered between the 25th and 28th. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34210460-sim-activation-delays-27-november-2024
Posted Nov 29, 2024 - 14:05 GMT
Update
Our technical teams are continuing to work hard on a resolution for this issue. As part of the fix the team are working on, there will be a temporary hold on SIM activations. This means all SIM activations will currently be impacted. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34210460-sim-activation-delays-27-november-2024
Posted Nov 29, 2024 - 11:16 GMT
Investigating
We’re currently seeing an issue impacting SIM activations from the 25th of November, meaning that some requests to activate SIM cards from this date are taking longer to process. We are currently investigating the cause of this and will keep you updated here. Read more here