Service updates

A snapshot of the giffgaff service

SIM activation with SIM's ordered on/after 21st October - 25th October 2024

Incident Report for giffgaff

Resolved

This incident has been resolved.
Posted Nov 22, 2024 - 15:44 GMT

Monitoring

Our technical teams have now confirmed that SIM activations that were incomplete during this period are now all transferred over. This means that if you experienced this issue, your SIM should now be fully activated. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34186489-resolved-sim-activation-issue-between-21st-oct-25th-oct-2024
Posted Nov 07, 2024 - 14:45 GMT

Update

After investigations, our technical team has found that SIM’s ordered on or after the 21st of October have been impacted by the activation issue, with some having delays or being unable to activate.
Posted Oct 28, 2024 - 12:06 GMT

Investigating

We’re currently seeing an issue impacting provisioning, meaning that some requests to activate SIM cards are taking longer to process. We are currently investigating the cause of this, and will keep you updated here.
Posted Oct 25, 2024 - 09:20 BST
This incident affected: SIM (Activating SIM).