Service updates

A snapshot of the giffgaff service

Porting delays - 13 May 2026

Incident Report for giffgaff

Resolved

This incident has been resolved.
Posted May 14, 2026 - 12:38 BST

Investigating

We have been notified that there is a slight delay for some members that are trying to port their number to and from giffgaff. This is currently being investigated by technical teams.

Afternoon folks,

We have been made aware that some members are experiencing delays with porting their number in to giffgaff and also porting their number away from giffgaff. The issue has been mitigated but, due to a significant back log it may take some time for that backlog to be processed and for the pending request to complete.

If you are currently having any other issues with services why not pop over to our Help & Support forum where our helpers will lend a hand. You can also browse our knowledge base here where you’ll find articles to guide you on specific issues.

We apologise for any inconvenience this may cause and thank members for their patience whilst we resolve this issue.

Simone
Posted May 13, 2026 - 15:05 BST
This incident affected: Transferring your number (Delayed Number Transfer).