Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 15, 2026 - 04:30 BST
Scheduled
We plan to complete an upgrade to our systems, which will result in giffgaff.com being placed into Maintenance Mode to mitigate member impact.
Posted Sep 14, 2026 - 16:10 BST
This scheduled maintenance affected: Transferring your number (Joining giffgaff), The My giffgaff app (Login, Availability), Community (Viewing the community, Interacting with the community, Notifications), Plans & Credit (Using a voucher, Using a credit/debit card, Using top-up credit, Using PayPal, IVR - Automated phone service, Display issues for plans & credit, Early repurchase, Travel Data Add On), Ask an agent (Raising a case, Case updates), SIM (Ordering a SIM, Activating SIM, SIM Swap), and giffgaff.com website (Login, Site availability, Registration).