Service updates

A snapshot of the giffgaff service

Some members unable to receive calls & texts - 22nd April 2024
Incident Report for giffgaff
Resolved
This incident has been resolved.
Posted May 01, 2024 - 09:39 BST
Monitoring
Our technical team have just informed us that they have been able to resolve the issue some members have been facing with receiving calls and texts.

https://community.giffgaff.com/d/34048265-restored-some-members-unable-to-receive-calls-texts-22nd-april-2024
Posted Apr 26, 2024 - 18:55 BST
Identified
Our technical team are continuing to work hard to resolve this issue. They have identified a possible cause of the issue and are working on a fix. You can learn more about this service issue via our community - https://community.giffgaff.com/d/34048265-some-members-unable-to-receive-calls-texts-22nd-april-2024
Posted Apr 23, 2024 - 10:26 BST
Investigating
We have had a few members reporting an issue with receiving incoming calls & text messages, and have let us know that the person calling their number hears a message stating that the ‘number is not recognised’and texts fail. We are currently investigating this issue, and advise any members currently experience this issue please raise a case with our agents, to help get this resolved.
https://community.giffgaff.com/d/34048265-some-members-unable-to-receive-calls-22nd-april-2024
Posted Apr 22, 2024 - 13:35 BST
This incident affected: Data, calls and texts (Calls and texts).