Service updates

A snapshot of the giffgaff service

Issue receiving calls from other networks - 17 April 2026

Incident Report for giffgaff

Investigating

We have been notified of a number of member cases being raised for issues receiving calls from other networks. Calls from VMo2 network numbers are still working as expected. We are currently investigating this issue and will keep you updated here.
Posted Apr 17, 2026 - 14:51 BST
This incident affects: Data, calls and texts (Calls).