Service updates

A snapshot of the giffgaff service

Issue with eSIM provisioning
Incident Report for giffgaff
Resolved
This incident has been resolved.
Posted Dec 23, 2024 - 11:28 GMT
Investigating
We are currently experiencing an issue with our provisioning service specifically impacting eSIM activations from December 15th, meaning members who tried to activate their eSIM on that date may be experiencing a delay in having their eSIM activated. Our technical team are currently investigating this issue. You can learn more about this Service Issue via our community - https://community.giffgaff.com/d/34227720-issue-with-esim-provisioning-15-december-2024
Posted Dec 20, 2024 - 10:56 GMT
This incident affected: SIM (Activating SIM, SIM Swap).