Service updates

A snapshot of the giffgaff service

Some Port In requests not fully completed | 18 February 2026

Incident Report for giffgaff

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 09:36 GMT

Investigating

We are seeing some Port in requests from yesterday (17/02/26) that still haven’t fully completed, the number appears to have been transferred successfully but when a call is made to the Ported number the message “number not recognised” is heard.
Read more here
Posted Feb 18, 2026 - 15:57 GMT
This incident affected: Transferring your number (Delayed Number Transfer).