Service updates

A snapshot of the giffgaff service

Phone Order Delays - 02 December 2024
Incident Report for giffgaff
Update
We have been informed of delays in phones delivery. The team is actively investigating the issue and we will provide further updates as soon as possible. Read more here
Posted Dec 06, 2024 - 14:44 GMT
Update
We are continuing to investigate this issue.
Posted Dec 06, 2024 - 14:42 GMT
Update
We are continuing to investigate this issue.
Posted Dec 06, 2024 - 14:39 GMT
Investigating
We have been informed of delays in phones delivery. The team is actively investigating the issue and we will provide further updates as soon as possible. Read more here
Posted Dec 02, 2024 - 12:51 GMT
This incident affects: Phones (Phone delivery).