We had reports recently that some members who have requested to port numbers into giffgaff since Friday 21st March were experiencing a delay in completion. We have now resolved this issue and the ports have been successfully completed.
Posted Mar 24, 2025 - 14:07 GMT
Investigating
We have had reports recently that a small number of members who have requested to port numbers into giffgaff since Friday 21st March are experiencing a delay in completion. We are currently investigating this issue and will keep you updated here.
Posted Mar 24, 2025 - 10:42 GMT
This incident affected: Transferring your number (Joining giffgaff).